红绿趋势线(通达信公式 副图 源码 测试图)(图文)

时间:2020-01-31 12:37:15 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

N:=12;

M:=26;

VARF:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);

VAR19:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);

VAR20:=VARF<REF(VAR19,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

大资金活动:IF(VAR20 AND COUNT(VAR20,30)=1,18,0),LINETHICK1,COLORRED;

STICKLINE(VAR20 AND COUNT(VAR20,30)=1,0,15,5,0),COLORRED;

DRAWTEXT(VAR20 AND COUNT(VAR20,30)=1,15,'大资金活动'),COLORRED;

VAR1:=(CLOSE*2+HIGH+LOW)/4*10;

VAR2:=EMA(VAR1,13)-EMA(VAR1,34);

VAR3:=EMA(VAR2,5);

VAR4:=2*(VAR2-VAR3)*5.5;

主力撤: IF(VAR4<=0,VAR4,0),COLORRED;

主力进: IF(VAR4>=0,VAR4,0),COLORGREEN;

VAR5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;

VAR6:=EMA(3*VAR5-2*SMA(VAR5,18,1),5);

VAR7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;

VAR8:=(INDEXC*2+INDEXH+INDEXL)/4;

VAR9:=EMA(VAR8,13)-EMA(VAR8,34);

VARA:=EMA(VAR9,3);

VARB:=(VAR9-VARA)/2;

大盘资金活动: IF(VARB>=0,VARB,0);

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VAR10:=(HIGH+LOW+CLOSE)/3;

VAR11:=(VAR10-MA(VAR10,14))/(0.015*AVEDEV(VAR10,14));

VAR12:=(VAR10-MA(VAR10,70))/(0.015*AVEDEV(VAR10,70));

VAR13:=IF(VAR11>=150 AND VAR11<200 AND VAR12>=150 AND VAR12<200,10,0);

VAR14:=IF(VAR11<=-150 AND VAR11>-200 AND VAR12<=-150 AND VAR12>-200,-10,VAR13);

VAR15:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100;

VAR16:=100-ABS(VAR15);

VAR17:=IF(VAR16<90,VAR16,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR12>=200 AND VAR11>=150,15,IF(VAR12<=-200 AND VAR11<=-150,-15,VAR14))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR17<100;


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)