神奇布林均线(同花顺公式 主图 源码 测试图)(图文)

时间:2020-02-18 11:23:23 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

BOLL:MA(CLOSE,20),colorwhite,linethick3;

upper:BOLL+2*STD(CLOSE,20),colorred,linethick3;

lower:BOLL-2*STD(CLOSE,20),colorgreen,linethick3;

拉升线:MA(CLOSE,5),colorgreen;

主力线:MA(CLOSE,10),colorlimagenta,linethick1;

ma20:=MA(CLOSE,20),colorlimagenta;

生命线:=MA(CLOSE,30),colorwhite,linethick3;

多空趋势60:=MA(CLOSE,60),color555555,linethick1;

半年线:=MA(CLOSE,120),colorblue,linethick1;

DRAWTEXT(CROSS(ma20,生命线),生命线*0.98,'回头买狂升'),colorgreen,linethick2;

DRAWTEXT(CROSS(生命线,多空趋势60),多空趋势60*0.98,'中线逢低买牛'),COLOR0000FF,linethick2;

DRAWTEXT(CROSS(多空趋势60,半年线),半年线*0.98,'锁定长牛'),COLOR999999,linethick2;

aa:=CLOSE/REF(C,1)>=1.09;

STICKLINE(aa,O,C,3,0),coloryellow;

STICKLINE(aa,L,H,0,0),coloryellow;

正向分形:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;

正向定位:=CROSS(C,正向分形) AND 正向分形>REF(正向分形,1);

STICKLINE(正向定位,H,L,0,1),colorligreen,LINETHICK2;

STICKLINE(正向定位,O,C,1.8,0),colorligreen,LINETHICK2;

AAA:=(3*C+H+L+O)/6;

VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;

立桩量:=FILTER(TJ1,5);

TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));

突破:=TJ2=1;

STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),colorcyan;

STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),coloryellow;

TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));

三天法则:=TJ3=1;

成立:=三天法则 AND 突破;

条件成立:=FILTER(成立,3);

DRAWTEXT(条件成立,L*0.99,'大资金进'),coloryellow;

Va1:=EMA(CLOSE,8);

Va2:=EMA(Va1,20);

Va3:=CROSS(Va1,Va2);

Va4:=VOL/SUM(VOL,13);

Va5:=DMA(CLOSE,Va4);

Va6:=Va1<MA(CLOSE,120);

A3a:=Va3 AND Va6 AND (CLOSE-Va5)/Va5*100/2.5>1.6;

A4a:=CROSS( (CLOSE-Va5)/Va5*100/2.5,0 ) AND (CLOSE-Va5)/Va5*100/2.5>1.5 ;

DRAWTEXT(A4a>0 OR A3a>0,L-0.3,'追'),colorwhite;

 


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)