飞龙在天(源码,主图,通达信、贴图)(图文)

时间:2020-03-30 10:29:43 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

飞龙在天(源码,主图,通达信、贴图)

 

以下是通达信飞龙在天主图指标公式源码

TS:=500;
N:=95;
M1:=5;
M2:=10;
DA1:=IF(TS>TOTALBARSCOUNT,TOTALBARSCOUNT,TS);
VA:=IF((DATETODAY(DATE))<11880,1,DRAWNULL);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
{最高价}LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
XAS:=IF(DATE<2442.46*500,1,DRAWNULL);
GZ:=EXP(LN(HI/LO)/15)*VA;
{对数格值}LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(HI/POW(GZ,9)) AND C1<LO*POW(GZ,7),V,0),DA);
LH10:=SUM(IF(C1>=(LO*POW(GZ,5)) AND C1<LO*POW(GZ,6),V,0),DA);
LH11:=SUM(IF(C1>=(LO*POW(GZ,4)) AND C1<LO*POW(GZ,5),V,0),DA);
LH12:=SUM(IF(C1>=(LO*POW(GZ,3)) AND C1<LO*POW(GZ,4),V,0),DA);
LH13:=SUM(IF(C1>=(LO*POW(GZ,2)) AND C1<LO*POW(GZ,3),V,0),DA);
LH14:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA)*XAS;
LH15:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA)*XAS;
L1:=REFDATE(HHV(LH1,DA),DATE);
L2:=REFDATE(HHV(LH2,DA),DATE);
L3:=REFDATE(HHV(LH3,DA),DATE);
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
L11:=REFDATE(HHV(LH11,DA),DATE);
L12:=REFDATE(HHV(LH12,DA),DATE);
L13:=REFDATE(HHV(LH13,DA),DATE);
L14:=REFDATE(HHV(LH14,DA),DATE);
L15:=REFDATE(HHV(LH15,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10+L11+L12+L13+L14+L15)*VA;
M13:MA(CLOSE,13);
先知趋势线:MA(CLOSE,34)*VA,COLORRED,LINETHICK2;
快线:(SUM(EMA((CLOSE+LOW)/2,1)/3,3))*VA,COLORRED,LINETHICK1;
中线:EMA(快线,3),COLOR00FFFF,LINETHICK1;
慢线:EMA(中线,3),COLORFF00FF,LINETHICK1;
{MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,30);
MA4:MA(CLOSE,120);
}STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR000055;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000088;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR0000AA;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000EE;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLOR666600;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR555500;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR888800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORAAAA00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBB00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORCCCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOREEEE00;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
AA11:=(C-REF(C,1))/REF(C,1)>=0.058 AND (C-REF(C,1))/REF(C,1)<0.095*XAS ;
AA22:=(C-REF(C,1))/REF(C,1)>=0.098*VA ;
STICKLINE(AA22,C,O,3,0 ),COLOR00AAFF;
STICKLINE(AA22,C,O,2.1,0 ),COLOR00BBFF;
STICKLINE(AA22,C,O,1.5,0 ),COLOR00CCFF;
STICKLINE(AA22,C,O,1,0 ),COLOR00DDFF;
STICKLINE(AA22,C,O,0.6,0 ),COLOR00EEFF;
STICKLINE(AA22,C,O,0.2,0 ),COLOR00FFFF

飞龙在天(源码,主图,通达信、贴图)



后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)